lucene-solr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris A. Mattmann (JIRA)" <j...@apache.org>
Subject [jira] Commented: (SOLR-1642) Change name of SOLR749Test
Date Wed, 13 Jan 2010 06:47:54 GMT

    [ https://issues.apache.org/jira/browse/SOLR-1642?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12799619#action_12799619
] 

Chris A. Mattmann commented on SOLR-1642:
-----------------------------------------

Any takers on this one? Hoss? Others?

Cheers,
Chris


> Change name of SOLR749Test
> --------------------------
>
>                 Key: SOLR-1642
>                 URL: https://issues.apache.org/jira/browse/SOLR-1642
>             Project: Solr
>          Issue Type: Improvement
>          Components: Build
>    Affects Versions: 1.3, 1.4
>         Environment: My local MacBook pro.
>            Reporter: Chris A. Mattmann
>            Priority: Trivial
>             Fix For: 1.5
>
>         Attachments: SOLR-1642.Mattmann.121009.patch.txt
>
>
> The test class named SOLR749Test is inconsistent with all of the rest of the unit tests,
which aren't tied to their JIRA issue names. Some examples of best practices:
> http://googletesting.blogspot.com/2007/02/tott-naming-unit-tests-responsibly.html
> http://blog.taragana.com/index.php/archive/java-unit-testing-best-practices/
> http://junit.sourceforge.net/doc/faq/faq.htm#best

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message