lucene-solr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shalin Shekhar Mangar <shalinman...@gmail.com>
Subject Re: Upgrading Lucene jars
Date Wed, 09 Dec 2009 11:55:39 GMT
On Wed, Dec 9, 2009 at 3:33 PM, Sanne Grinovero
<sanne.grinovero@gmail.com>wrote:

> Why is Solr not depending directly on Lucene but repackaging the same
> classes?
>
>
Solr does depend on Lucene jars. We strive to package officially released
Lucene artifacts but sometimes the release schedule of Lucene and Solr are
different enough to build and package Lucene jars ourselves. The CHANGES.txt
in the Solr distribution has the version of Lucene used in that
distribution. For example, Solr 1.4 released with Lucene 2.9.1

Solr 1.4 has already released and we are free to upgrade Lucene jars in
trunk to any version we desire for further development.


> Sorry I've probably missed some important discussion. Whatever the
> reason for this decision, is it still a good reason?
>
> This gets new users in a hell of trouble sometimes, as some
> applications introduce Solr after having Lucene already on the
> classpath and it's not immediately obvious that differently named jars
> contain same named classes.
>

Are you using Embedded Solr? Otherwise the Lucene jars are in the solr.war's
WEB-INF/lib directory and there is no chance of a conflict.

-- 
Regards,
Shalin Shekhar Mangar.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message