lucene-solr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Borgermans <paul.borgerm...@gmail.com>
Subject Re: Solr 1.5 or 2.0?
Date Thu, 19 Nov 2009 15:00:09 GMT
On Thu, Nov 19, 2009 at 3:31 PM, Yonik Seeley
<yonik@lucidimagination.com> wrote:
> What should the next version of Solr be?
>
> Options:
> - have a Solr 1.5 with a lucene 2.9.x
> - have a Solr 1.5 with a lucene 3.x, with weaker back compat given all
> of the removed lucene deprecations from 2.9->3.0
> - have a Solr 2.0 with a lucene 3.x

IMHO, Solr 2.0 given the removed deprecations in Lucene 3.0 and the
typical mindset that major versions indicate BC breaks

This can then also be used to remove deprecated Solr bits as well

Just my €0.0.2

Paul

Mime
View raw message