lucene-solr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Rosenthal (JIRA)" <j...@apache.org>
Subject [jira] Created: (SOLR-1509) Admin UI display of schema.xml can't find schema file
Date Tue, 13 Oct 2009 18:16:31 GMT
Admin UI display of schema.xml can't find schema file
-----------------------------------------------------

                 Key: SOLR-1509
                 URL: https://issues.apache.org/jira/browse/SOLR-1509
             Project: Solr
          Issue Type: Bug
    Affects Versions: 1.4
            Reporter: Simon Rosenthal
            Priority: Minor



This is in a multicore enviroment:   solr.xml contains

<solr sharedLib="lib" shareSchema="true" persistent="true">
	<cores adminPath="/admin/cores">
		<core default="true" instanceDir="core1" name="core1"
                 config="/home/solrdata/rig1/conf/solrconfig.xml" 
                 schema="/home/solrdata/rig1/conf/schema.xml" >
        <property name="dataDir" value="/home/solrdata/rig1/core1" />
    </core>
		<core default="false" instanceDir="core2" name="core2"
        ... schema same as above
    </core>
	...
	</cores>
	
	When I go to the URL /solr/core1/admin/ and click on the schema link, the URL displayed by
the browser is 

	http://host:port/solr/core1/admin/file/?file=/home/solrdata/rig1/conf/schema.xml
	
	which looks correct,  but a HTTP 400 error is displayed in of the form
	
	Can not find: schema.xml [/path/to/core1/conf/directory/home/solrdata/rig1/conf/schema.xml]
	
	looks as though it's blindly appending the schema.xml path to the conf directory, even though
it's not a relative one. 
        Same for other cores

       The schema browser link on the admin page works fine.



-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message