lucene-solr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (JIRA)" <>
Subject [jira] Commented: (SOLR-1396) standardize the updateprocessorchain syntax
Date Wed, 09 Sep 2009 04:38:57 GMT


Hoss Man commented on SOLR-1396:

bq. This is for standardization. the searchcomponent has a similar configuration

but search components _are_ a pluggable, and have a generic init(NamedList) method ... so
do request handlers, and i think what you are refering to is the way the component list for
a SearchHandler instance is specified -- in that case named arrays are included in the broader
NamedList of the init method to distibguish what it is (because some RequestHandlers could
have all sorts of other init params.

but if updateRequestProcessorChain isn't going to be pluggable (as you said: we don't need
a class attribute) then we don't need to worry about providing generalized init param support
for it ... so we can keep the syntax simple.

really it just comes down to whether or not update processors can really be refrenced by name
and reused in multiple chains.  if they can't this is all moot, but if they can then it would
certianly make sense to give them names, and break them out like you describe, and then keep
the chains simple...

  <updateRequestProcessorChain name="dedupe">

> standardize the updateprocessorchain syntax
> -------------------------------------------
>                 Key: SOLR-1396
>                 URL:
>             Project: Solr
>          Issue Type: Improvement
>            Reporter: Noble Paul
>             Fix For: 1.4
> updateprocessorChain follows a non-standard syntax in solr . Usually, all the components
are initialized as top level components and they are assembled and used using a NamedList
syntax .for example search components.
> I propose to change it as follows
> {code:xml}
>  <updateRequestProcessorChain name="custom" class="solr.UpdateRequestProcessorChain">

>   <arr name="chain">
>       <str>custom</str>
>       <str>runUpdate</str>
>       <str>log</str>
>   </arr>
> </updateRequestProcessorChain>
> <updateProcessor name="custom" class="solr.CustomUpdateRequestProcessorFactory" >
>    <lst name="name">
>      <str name="n1">x1</str>
>      <str name="n2">x2</str>
>    </lst>
> </updateProcessor>                                    
> <updateProcessor name="runUpdate" class="solr.RunUpdateProcessorFactory" />   
> <updateProcessor name="log" class="solr.LogUpdateProcessorFactory" />   
> {code}
> The wiki documentation says this was supposed to be reviewed. If possible we should clean
it up in 1.4 itself. We can support the old syntax too

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message