lucene-solr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (JIRA)" <j...@apache.org>
Subject [jira] Commented: (SOLR-1396) standardize the updateprocessorchain syntax
Date Fri, 04 Sep 2009 00:45:58 GMT

    [ https://issues.apache.org/jira/browse/SOLR-1396?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12751250#action_12751250
] 

Hoss Man commented on SOLR-1396:
--------------------------------


* a ref by name syntax like this would make it possible for two separate chains to both contain
the same processor, or for a single processor to occur multiple times in the same chain ...
i have no idea if this would break things, but it's something that should be considered
* i don't see a reason why updateRequestProcessorChain needs a class attribute ... it's just
a simple container around the processors, is there a use case for making it pluggable?
** unless we make the processor chain class pluggable, there's no reason for an explict array
containing hte names of the processors, the top level list under the processor chain can be
used (as it is now - just with names instead of the processors themselves)

> standardize the updateprocessorchain syntax
> -------------------------------------------
>
>                 Key: SOLR-1396
>                 URL: https://issues.apache.org/jira/browse/SOLR-1396
>             Project: Solr
>          Issue Type: Improvement
>            Reporter: Noble Paul
>             Fix For: 1.4
>
>
> updateprocessorChain follows a non-standard syntax in solr . Usually, all the components
are initialized as top level components and they are assembled and used using a NamedList
syntax .for example search components.
> I propose to change it as follows
> {code:xml}
>  <updateRequestProcessorChain name="custom" class="solr.UpdateRequestProcessorChain">

>   <arr name="chain">
>       <str>custom</str>
>       <str>runUpdate</str>
>       <str>log</str>
>   </arr>
> </updateRequestProcessorChain>
> <updateProcessor name="custom" class="solr.CustomUpdateRequestProcessorFactory" >
>    <lst name="name">
>      <str name="n1">x1</str>
>      <str name="n2">x2</str>
>    </lst>
> </updateProcessor>                                    
> <updateProcessor name="runUpdate" class="solr.RunUpdateProcessorFactory" />   
                
> <updateProcessor name="log" class="solr.LogUpdateProcessorFactory" />   
> {code}
> The wiki documentation says this was supposed to be reviewed. If possible we should clean
it up in 1.4 itself. We can support the old syntax too

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message