lucene-solr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Bennett <mbenn...@ideaeng.com>
Subject Anybody using Japanese SEN with recent versions of Solr ?
Date Mon, 29 Jun 2009 23:42:31 GMT
I've been reading through the SEN project doc and various Japanese blogs,
but still having some issues.

In particular, it seems like perhaps you're supposed to have BOTH
sen-1.2.2.1 and lucene-ja-2.0test2 installed?

I guess the lucene-ja is an adapter layer between the org.apache.lucene
analyzers and base net.java Tokenizers, whereas sen-1.2.2.1 is the base SEN
package, and is not aware of Lucene/Solr.  So I guess you need both.

But both versions have Lucene classes, and the lucene-ja stuff seems to be
using very old Lucene.  I'm not sure how you layer this all together with a
more recent Solr implemenation?  (using nightly stable)

Or perhaps the older lucene-ja is intended to already have SEN, it does have
some SEN files, but they are quite a bit older than the SEN 1221 stuff, and
you've still got the old Lucene version issue.

Any input would be appreciated.

--
Mark Bennett / New Idea Engineering, Inc. / mbennett@ideaeng.com
Direct: 408-733-0387 / Main: 866-IDEA-ENG / Cell: 408-829-6513

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message