lucene-solr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amit Nithian (JIRA)" <>
Subject [jira] Commented: (SOLR-1137) Improve package naming for DIH
Date Fri, 01 May 2009 07:19:30 GMT


Amit Nithian commented on SOLR-1137:

I thought one of the bugs/features was to make DIH more API friendly so I figured this would
be a good way to do so. Also, many of the comments indicate that the API is subject to change
so I didn't think much of backwards compatibility due to this statement.

regarding the user seeing the benefit, the common end-user won't but from a developer's perspective,
it just keeps the code more organized and cleaner.

> Improve package naming for DIH
> ------------------------------
>                 Key: SOLR-1137
>                 URL:
>             Project: Solr
>          Issue Type: Improvement
>          Components: contrib - DataImportHandler
>    Affects Versions: 1.3
>            Reporter: Amit Nithian
>            Priority: Minor
> Currently all classes in the DIH are lumped into one package. I would like to propose
a better package naming convention for the DIH:
> org.apache.solr.handler.dataimport => for those that don't fit into any of the other
three but don't warrant their own package yet.
> org.apache.solr.handler.dataimport.datasource
> org.apache.solr.handler.dataimport.transformer
> org.apache.solr.handler.dataimport.processor
> Create a test folder and mirror the package names for test classes so that test classes
are not lumped into src 

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message