lucene-solr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yonik Seeley" <yo...@apache.org>
Subject Re: NullPointerException when posting file
Date Tue, 19 Dec 2006 20:29:44 GMT
Hi Mike,
Is the attached schema the whole thing?  It looks like the first half
of the file is missing.

-Yonik

On 12/19/06, Mike <mpiluso@comcast.net> wrote:
> Hi,
>
> I'm trying to get SOLR up and running with a simple example of my own. The
> sample data files provided in the example/exampledocs directory import
> flawlessly, as well as querying for their contents through the admin UI. I
> know I'm missing something basic, but I just can't figure it out :) I
> apologize in advance if this is terribly obvious.
>
> The attached sample.txt is my sample XML file consisting of four data
> fields. When I post this document to SOLR, I get a null pointer exception
> (see exception.txt for actual command and output). I'm using the default
> schema.xml with some minor changes to the <fields> section to match my
> sample data. I also add three of these fields to the "text" field to combine
> them together.
>
> If it matters, I'm using Apache Tomcat 5.5.20. In the
> conf/Catalina/localhost/solr.xml file, I have:
>
> """
> <Context docBase="solr.war" debug="0" crossContext="true" >
>    <Environment name="solr/home" type="java.lang.String"
> value="/var/lib/solr_bg" override="true" />
> </Context>
> """
>
> Thanks for your time.
>
> Mike

Mime
View raw message