lucene-solr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Hostetter <hossman_luc...@fucit.org>
Subject Re: Schema Parsing Failed, fix?
Date Fri, 22 Dec 2006 08:19:11 GMT

: I have the trunk version with patch #1 on SOLR-78 (the one edited at
: 11:59am).  When i run the war file on a windows machine running
: resin-3.0.21 it works fine.  When i run it on a linux box (debian)
: also running resin-3.0.21, i get:

ah .. okay, so you never tried the older version (i thought you ment you
had personally applied one of hte patches to your local copy)

: [00:25:35.025] Caused by: java.lang.NumberFormatException: empty String
: [00:25:35.025]  at
: sun.misc.FloatingDecimal.readJavaFormatString(FloatingDecimal.java:994)
: [00:25:35.025]  at java.lang.Float.parseFloat(Float.java:394)
: [00:25:35.025]  at org.apache.solr.core.Config.getFloat(Config.java:174)
: [00:25:35.025]  at
: org.apache.solr.schema.IndexSchema.readConfig(IndexSchema.java:273)

Ah .. interesting ... that's parsing the version number from the schema,
and by the looks of it it's not getting the default version but an empty
string instead.

can you verify two things for me...

1) i'm assuming the <schema> tag in your schema.xml either doesn't have a
version="" attribute in it, or has an empty string (or pure white space)
as the value, is that correct?

2) can you try running resin with the java logging level at "fine" and
looking for a log line that includes the string "/schema/@version" and let
us know what it says?


Config.getFloat(path,def) only uses the default value if
getVal(path,false) returns null -- but i'm guessing DOMUtil.getText(Node)
is returning the empty string.

so is this a bug in the DOMUtil.getText(NOde) method i wrote, or should we
change Config.getVal, or should we change all of the Config.get*(path,def)
methods to use the default if getVal returns am empty string?


Mime
View raw message