lucene-solr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manuel Albela Miranda <alb...@3.14financial.com>
Subject Re: Solr, new index format (segments_N)
Date Thu, 30 Nov 2006 17:41:31 GMT
Michael McCandless wrote:
> Yonik Seeley wrote:
>> On 11/28/06, Manuel Albela Miranda <albela@3.14financial.com> wrote:
>>> Thanks for your answer. Yes, i'm using Sun's JDK 1.5.0 too. Can you 
>>> tell
>>> me the step you followed to get solr running with the lockless 
>>> commits?.
>>> I compile the latest java lucene and then put the jar files 
>>> generated in
>>> the lib directory of the solr distribution. Finally running 'ant' it
>>> compiles without any problem. But when trying the example with the new
>>> index format, it fails.
>
> These are the steps I did (with Sun's JDK 1.5.0):
>
>   * Checked out the current trunk of Solr (from svn)
>
>   * Checked out the current trunk of Lucene (from svn)
>
>   * Built the Lucene JARs ("ant jar-core")
>
>   * Copied jar to Solr dir:
>
>       "cp build/lucene-core-2.1-dev.jar 
> ../solr/lib/lucene-core-nightly.jar"
>
>   * Then ran "ant example" in solr dir (which creates solr.war under
>     example/webapps).
>
>   * Start jetty (cd example; java -jar start.jar)
>
>   * Submit all the xml files (cd exampledocs; sh post.sh *.xml)
>
>   * Verified that index (example/solr/data/index/*) shows segments_N
>     file (not segments), to confirm lockless is in fact running.
>
>   * Ran some searches, did some more of the examples (using curl to
>     delete & commit, etc.), and they all seem to be working fine.
>
> Mike
>
>
>

Hi Mike,

Thanks again for your pacience. I have followed all the steps, but with 
the same result. I use Solr with apache, but as you do, i tried with 
Jetty, but the problem still remains with Jetty and Apache.

The error message is:

java.lang.RuntimeException: java.lang.UnsatisfiedLinkError: matches
	at org.apache.solr.core.SolrCore.getSearcher(SolrCore.java:362)
	at org.apache.solr.core.SolrCore.getSearcher(SolrCore.java:258)
	at org.apache.solr.request.SolrQueryRequestBase.getSearcher(SolrQueryRequestBase.java:152)
	at org.apache.solr.request.StandardRequestHandler.handleRequest(StandardRequestHandler.java:126)
	at org.apache.solr.core.SolrCore.execute(SolrCore.java:587)
	at org.apache.solr.servlet.SolrServlet.doGet(SolrServlet.java:92)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
	at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
	at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
	at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
	at java.lang.Thread.run(Thread.java:595)
Caused by: java.lang.UnsatisfiedLinkError: matches
	at org.apache.lucene.index.IndexFileNameFilter.matches(Native Method)
	at org.apache.lucene.index.IndexFileNameFilter.accept(IndexFileNameFilter.java:51)
	at java.io.File.list(File.java:974)
	at org.apache.lucene.store.FSDirectory.list(FSDirectory.java:328)
	at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfos.java:427)
	at org.apache.lucene.index.IndexReader.open(IndexReader.java:143)
	at org.apache.lucene.index.IndexReader.open(IndexReader.java:127)
	at org.apache.solr.search.SolrIndexSearcher.<init>(SolrIndexSearcher.java:85)
	at org.apache.solr.core.SolrCore.getSearcher(SolrCore.java:353)
	... 21 more


If you have any idea i will appreciate it.

Regards.

Manu

Mime
View raw message