lucene-solr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Solr Wiki] Update of "SolrInstall" by HossMan
Date Mon, 13 Dec 2010 20:02:32 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Solr Wiki" for change notification.

The "SolrInstall" page has been changed by HossMan.
The comment on this change is: java6 in solr4, and link to SOLR-2271.
http://wiki.apache.org/solr/SolrInstall?action=diff&rev1=24&rev2=25

--------------------------------------------------

  <<TableOfContents>>
  
  == Requirements ==
-  * Java5 or greater installed
+  * Java5 or greater installed. (Note: starting with Solr 4, Java 1.6 will be required)
   * A servlet container such as Tomcat, Jetty, or Resin
   * A [[http://people.apache.org/builds/lucene/solr/nightly/|Solr distribution]]
-  * Although Solr strives to be agnostic of the Locale where the server is running, some
code paths may inadvertently be depending on the System default Locale, or Charset.  It is
recommended that when running Solr you set the following system properties: {{{-Duser.language=en
-Duser.country=US}}}
+  * Although Solr strives to be agnostic of the Locale where the server is running, some
code paths may inadvertently be depending on the System default Locale, or Charset. (In particular,
there are [[https://issues.apache.org/jira/browse/SOLR-2271|known bugs in Sun's JVM dealing
with XSLTs in non English locales]])  It is recommended that when running Solr you set the
following system properties: {{{-Duser.language=en -Duser.country=US}}}
  
  == Setup ==
   * Stop your servlet container

Mime
View raw message