lucene-pylucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Koch <k...@orbiteam.de>
Subject Re: Installing PyLucene
Date Thu, 12 Jan 2017 09:54:27 GMT
Dear Petrus, 
thanks for your feedback - good to know that it’s useful for you application. And at least
one more user who asks for Python3 Support in JCC ,-)

best regards,
Thomas 
—
> Am 11.01.2017 um 23:14 schrieb Petrus Hyvönen <petrus.hyvonen@gmail.com>:
> 
> Dear Thomas,
> 
> Thanks for the patch files, I am not using pylucene so I have not tried that part, I
am wrapping another java library (orekit). I have now built a JCC on your JCC patch applied
on JCCv2.22. The test suite and application I have for my project runs fine with this patch
under python 3, on mac, linux and windows, I saw no deviations in behavior of the library
compared to v2.7. This is by far not a very deep test suite, but very good news.
> 
> With Best Regards
> /Petrus
> 
> 
> 
>> On 06 Jan 2017, at 10:07 , Thomas Koch <koch@orbiteam.de <mailto:koch@orbiteam.de>>
wrote:
>> 
>> 
>>> Am 04.01.2017 um 10:59 schrieb Petrus Hyvönen <petrus.hyvonen@gmail.com <mailto:petrus.hyvonen@gmail.com>>:
>>> 
>>> Dear Thomas,
>>> 
>>> I would be very interested in a python 3 port of JCC. I am not a very skilled
developer, looked at starting a development based on the old python-3 version but it's beyond
my current skills.
>>> 
>>> I would be happy to help and test and review the JCC patches, I think your patches
would be a valuable contribution to JCC.
>>> 
>>> With Best Regards
>>> /Petrus
>>> 
>> 
>> Dear Petrus,
>> the "patch" is available in this gist
>> https://gist.github.com/tommykoch/8b3cec18d6f3650d05d235c46ba3b055 <https://gist.github.com/tommykoch/8b3cec18d6f3650d05d235c46ba3b055>
>> 
>> It consists of 3 files:
>>  - one build script (build.py)
>>  - a patch file for jcc (pylucene_3_6-jcc-P3.patch)
>>  - a patch file for pylucene3.6 (pylucene_3_6-P3.patch)
>>   
>> in our environment the 3 files are located in 
>>  <root>/tools/build/pylucene
>> and the output (i.e. patched Pylucene36) is created in
>>  <root>/build
>>  
>> if you create this structure you may simply run
>> $ cd tools/build/pylucene
>> $ build.py build
>> 
>> which will checkout Pylucene36 from SVN (in <root>/build), apply the patch
files and build JCC and PyLucene.
>> The Script is intended to run on Linux (or MacOS) - a diff binary and svn installation
is required.
>> 
>> also easy_install(3) is needed to install the generated egg files -
>> besides the usual requirements for a PyLucene build (python3.4+, Java, gcc ...)
>> 
>> IMPORTANT NOTES:
>> - the patch is "one way" i.e. the patched Pylucene36 won't work with Py27 anymore!
>> - the patch is for the old (and outdated) PyLucene36 version only - it has not yet
been tested/ported to newer versions of JCC/Pylucene
>> - the patched JCC has only been used/tested with PyLucene - not with any other Java
library
>> 
>> A review of a core developer of JCC/Pylucene would also be good - I’ll ask Andi
what he thinks about this suggestion.
>> 
>> best regards,
>> 
>> Thomas
> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message