lucene-pylucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andi Vajda <va...@apache.org>
Subject Re: Can't build on Mavericks (different issue)
Date Fri, 28 Mar 2014 07:05:31 GMT

> On Mar 28, 2014, at 5:58, Mike McCormick <mccormick@runbox.com> wrote:
> 
> Hi folks,
> 
> I am trying to build jcc to install JModelica.  The linking process dies:
> 
> building 'jcc' extension
> gcc -DNDEBUG -g -fwrapv -Os -Wall -Wstrict-prototypes -Qunused-arguments -dynamiclib
-D_jcc_lib -DJCC_VER="2.19" -I/Library/Java/JavaVirtualMachines/jdk1.8.0.jdk/Contents/Home/include
-I/Library/Java/JavaVirtualMachines/jdk1.8.0

You're building against Java 8 which has not yet been tested with jcc. It may work, or not.

> .jdk/Contents/Home/include/darwin -I_jcc -Ijcc/sources -I/System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7
-c jcc/sources/jcc.cpp -o build/temp.macosx-10.9-intel-2.7/jcc/sources/jcc.o -DPYTHON -fno-strict-aliasing
-Wno-write-strings
> gcc -DNDEBUG -g -fwrapv -Os -Wall -Wstrict-prototypes -Qunused-arguments -dynamiclib
-D_jcc_lib -DJCC_VER="2.19" -I/Library/Java/JavaVirtualMachines/jdk1.8.0.jdk/Contents/Home/include
-I/Library/Java/JavaVirtualMachines/jdk1.8.0.jdk/Contents/Home/include/darwin -I_jcc -Ijcc/sources
-I/System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c jcc/sources/JCCEnv.cpp
-o build/temp.macosx-10.9-intel-2.7/jcc/sources/JCCEnv.o -DPYTHON -fno-strict-aliasing -Wno-write-strings
> g++ -Wl,-x -dynamiclib -undefined dynamic_lookup -Qunused-arguments build/temp.macosx-10.9-intel-2.7/jcc/sources/jcc.o
build/temp.macosx-10.9-intel-2.7/jcc/sources/JCCEnv.o -o build/lib.macosx-10.9-intel-2.7/libjcc.dylib
-L/Library/Java/JavaVirtualMachines/jdk1.8.0.jdk/Contents/Home/jre/lib -ljava -L/Library/Java/JavaVirtualMachines/jdk1.8.0.jdk/Contents/Home/jre/lib/server
-ljvm -Wl,-rpath -Wl,/Library/Java/JavaVirtualMachines/jdk1.8.0.jdk/Contents/Home/jre/lib
-Wl,-rpath -Wl,/Library/Java/JavaVirtualMachines/jdk1.8.0.jdk/Contents/Home/jre/lib/server
-Wl,-S -install_name @rpath/libjcc.dylib -current_version 2.19 -compatibility_version 2.19
> ld: internal error: atom not found in symbolIndex(__ZN7JNIEnv_13CallIntMethodEP8_jobjectP10_jmethodIDz)
for architecture x86_64
> clang: error: linker command failed with exit code 1 (use -v to see invocation)
> error: command 'g++' failed with exit status 1
> bash-3.2# 
> 
> I tried using Xcode and GCC and both stop with the same error at the same point in the
process.  Any idea how to approach troubleshooting this?

The linker error could be due to a mismatch between header files version and jre library version.
Also, jdk 8 is still untested against jcc.

Andi..

>  The packages available via pip and easy_install do the same thing.m
> 
> M

Mime
View raw message