lucene-pylucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andi Vajda <va...@apache.org>
Subject Re: [VOTE] Release PyLucene 4.5.0-1
Date Sat, 12 Oct 2013 07:52:43 GMT


On Sat, 12 Oct 2013, Steve Rowe wrote:

> Andi, TL;DR: success! installing setuptools 1.1.6 allowed the PyLucene 4.5 install to
succeed.
>
> I have several Python versions on my laptop, each of which seems to have at least one
setuptools installed with it.  The one for Python 2.7.2 is here:
>
> /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/
>
> and __init__.py in the above directory has this line:
>
>    __version__ = '0.6c12'
>
> Is there some other way to determine the setuptools version?

Yes, at the python prompt enter this:
   from pkg_resources import require
   require('setuptools')[0]
The output includes the setuptools pedigree you have installed.

For example, with setuptools 1.1.6, you get:
setuptools 1.1.6 (/Users/vajda/apache/pylucene-st/_install/lib/python2.7/site-packages/setuptools-1.1.6-py2.7.egg)

> I installed setuptools v1.1.6 using the instructions here: <https://pypi.python.org/pypi/setuptools/1.1.6#upgrading-from-setuptools-0-6>,
>
> (I see that the above-mentioned __init__.py still has the same __version__ - not sure
what that means?)
>
> Anyway, this (apparently) allowed the installation process to succeed!
>
> Here's the output I get at the end after I re-unpacked the pylucene distribution and
ran 'make && sudo make install':
>
> -----
> creating /Library/Python/2.7/site-packages/lucene-4.5.0-py2.7-macosx-10.8-intel.egg
> Extracting lucene-4.5.0-py2.7-macosx-10.8-intel.egg to /Library/Python/2.7/site-packages
> Removing lucene 4.5.0 from easy-install.pth file
> Adding lucene 4.5.0 to easy-install.pth file
>
> Installed /Library/Python/2.7/site-packages/lucene-4.5.0-py2.7-macosx-10.8-intel.egg
> Processing dependencies for lucene==4.5.0
> Finished processing dependencies for lucene==4.5.0

Great !
Does 'make test' pass all tests ?

Andi..

> -----
>
> Steve
>
> On Oct 11, 2013, at 3:30 PM, Andi Vajda <vajda@apache.org> wrote:
>> On Fri, 11 Oct 2013, Steve Rowe wrote:
>>
>>> I really have no idea where to start looking to figure out what's happening -
I'm not a big python user - any ideas?
>>>
>>> Would it be useful to package up my make'd directory and send it to you?
>>
>> I don't know yet. Do you know which version of setuptools you have
>> installed ?
>>
>> I'm currently battling an issue with the "third generation" setuptools,
>> v 1.1.6.
>> If you don't have something like 0.6something or 0.7 installed, please try that (for
lack of any better ideas, sorry).
>>
>> Andi..
>>
>>>
>>> Steve
>>>
>>> On Oct 10, 2013, at 7:34 PM, Andi Vajda <vajda@apache.org> wrote:
>>>
>>>> On Thu, 10 Oct 2013, Steve Rowe wrote:
>>>>
>>>>> Meant to send to the mailing lists:
>>>>>
>>>>> Begin forwarded message:
>>>>>
>>>>>> From: Steve Rowe <sarowe@gmail.com>
>>>>>> Subject: Re: [VOTE] Release PyLucene 4.5.0-1
>>>>>> Date: October 10, 2013 3:18:50 AM EDT
>>>>>> To: Andi Vajda <vajda@apache.org>
>>>>>>
>>>>>> Andi,
>>>>>>
>>>>>> I thought I'd run 'make' and 'sudo make install' in two steps, so
I checked, and bash 'history' agreed:
>>>>>>
>>>>>> 586  vi Makefile
>>>>>> 587  make
>>>>>> 588  sudo make install
>>>>>>
>>>>>> I tried again, first rm -rf'ing the unpacked distribution, then unpacking,
(skipping the jcc 'make' and 'sudo make install' this time), editing the Makefile, then running
'make', then 'sudo make install', and I got the same error - I suppose this is the most salient
line:
>>>>
>>>> The problem is that I can't even reproduce the error.
>>>> You're not the first one to report it but it usually "goes away" :-(
>>>> Stuck.
>>>>
>>>> Andi..
>>>>
>>>>>>
>>>>>> -----
>>>>>> No local packages or download links found for lucene==4.5.0
>>>>>> -----
>>>>>>
>>>>>> Steve
>>>>>>
>>>>>> On Oct 10, 2013, at 2:59 AM, Andi Vajda <vajda@apache.org>
wrote:
>>>>>>> Hi Steve,
>>>>>>>
>>>>>>> On Thu, 10 Oct 2013, Steve Rowe wrote:
>>>>>>>
>>>>>>>> After make'ing and installing jcc (no setup.py changes required);
uncommenting the first Mac OS X 10.6 section in Makefile (I have OS X 10.8.5, with stock Python
2.7.2 and Oracle Java 1.7.0_25); and finally make'ing pylucene: 'sudo make install' fails
- here's the tail end of the output:
>>>>>>>>
>>>>>>>> -----
>>>>>>>> writing build/bdist.macosx-10.8-x86_64/egg/EGG-INFO/native_libs.txt
>>>>>>>> creating dist
>>>>>>>> creating 'dist/lucene-4.5.0-py2.7-macosx-10.8-x86_64.egg'
and adding 'build/bdist.macosx-10.8-x86_64/egg' to it
>>>>>>>> removing 'build/bdist.macosx-10.8-x86_64/egg' (and everything
under it)
>>>>>>>> Processing lucene-4.5.0-py2.7-macosx-10.8-x86_64.egg
>>>>>>>> creating /Library/Python/2.7/site-packages/lucene-4.5.0-py2.7-macosx-10.8-x86_64.egg
>>>>>>>> Extracting lucene-4.5.0-py2.7-macosx-10.8-x86_64.egg to /Library/Python/2.7/site-packages
>>>>>>>> Removing lucene 4.4.0 from easy-install.pth file
>>>>>>>> Adding lucene 4.5.0 to easy-install.pth file
>>>>>>>>
>>>>>>>> Installed /Library/Python/2.7/site-packages/lucene-4.5.0-py2.7-macosx-10.8-x86_64.egg
>>>>>>>> Processing dependencies for lucene==4.5.0
>>>>>>>> Searching for lucene==4.5.0
>>>>>>>> Reading http://pypi.python.org/simple/lucene/
>>>>>>>> Couldn't find index page for 'lucene' (maybe misspelled?)
>>>>>>>> Scanning index of all packages (this may take a while)
>>>>>>>> Reading http://pypi.python.org/simple/
>>>>>>>> No local packages or download links found for lucene==4.5.0
>>>>>>>> error: Could not find suitable distribution for Requirement.parse('lucene==4.5.0')
>>>>>>>
>>>>>>> This error has been a problem for a while.
>>>>>>> You need to make, then make install, in two steps.
>>>>>>> Otherwise, when 'make install' in pylucene from clean, this error
seems to happen. I don't know of a fix.
>>>>>>>
>>>>>>> Andi..
>>>>>>>
>>>>>>>> make: *** [install] Error 1
>>>>>>>> -----
>>>>>>>>
>>>>>>>> I've included the entire 'sudo make install' output here:
<https://paste.apache.org/8gAF>
>>>>>>>>
>>>>>>>> Steve
>>>>>>>>
>>>>>>>> On Oct 8, 2013, at 1:00 AM, Andi Vajda <vajda@apache.org>
wrote:
>>>>>>>>
>>>>>>>>>
>>>>>>>>> The PyLucene 4.5.0-1 release tracking the recent release
of Apache Lucene 4.5.0 is ready.
>>>>>>>>>
>>>>>>>>> A release candidate is available from:
>>>>>>>>> http://people.apache.org/~vajda/staging_area/
>>>>>>>>>
>>>>>>>>> A list of changes in this release can be seen at:
>>>>>>>>> http://svn.apache.org/repos/asf/lucene/pylucene/branches/pylucene_4_5/CHANGES
>>>>>>>>>
>>>>>>>>> PyLucene 4.5.0 is built with JCC 2.17 included in these
release artifacts:
>>>>>>>>> http://svn.apache.org/repos/asf/lucene/pylucene/trunk/jcc/CHANGES
>>>>>>>>>
>>>>>>>>> A list of Lucene Java changes can be seen at:
>>>>>>>>> http://svn.apache.org/repos/asf/lucene/dev/tags/lucene_solr_4_5_0/lucene/CHANGES.txt
>>>>>>>>>
>>>>>>>>> Please vote to release these artifacts as PyLucene 4.5.0-1.
>>>>>>>>>
>>>>>>>>> Thanks !
>>>>>>>>>
>>>>>>>>> Andi..
>>>>>>>>>
>>>>>>>>> ps: the KEYS file for PyLucene release signing is at:
>>>>>>>>> http://svn.apache.org/repos/asf/lucene/pylucene/dist/KEYS
>>>>>>>>> http://people.apache.org/~vajda/staging_area/KEYS
>>>>>>>>>
>>>>>>>>> pps: here is my +1
>>>>>>>>
>>>>>>>>
>>>>>>
>>>>>
>>>>>
>>>
>>>
>
>

Mime
View raw message