lucene-pylucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael McCandless <luc...@mikemccandless.com>
Subject Re: SynonymAnalyzer(s) in PyLucene34
Date Thu, 27 Oct 2011 13:40:22 GMT
On Thu, Oct 27, 2011 at 9:09 AM, Andi Vajda <vajda@apache.org> wrote:

> So, I downloaded the new version of the samples, hoping to find a new
> version of the wordnet index. But first, following instructions in README,
> running 'ant test' in the lia2e directory fails with:
>    Testcase: testWriteLock(lia.indexing.LockTest):     Caused an ERROR
>    [junit] Unknown format version: -11
> during the CreateTestIndex step. Mike, what could that be ? (running Lucene
> 3.4.0)

Hmmm, odd.  I couldn't reproduce this.  First I tried w/ the ZIP as
downloaded.  Then, I replaced the lib/lucene-core-3.0.2.jar with the
3.4.0 jar.  (Separately, I removed lucene-*-dev.jar: not sure why
those are in the zip file!).  "ant test" ran fine both times.

Did the LockTest fail or was it really during CreateTestIndex?  It
sounds like somehow something is opening a newer Lucene index than 3.x
(format -11 is likely referring to the segments file, which was added
for 3.1; so likely somehow it's using Lucene 3.0.x and trying to
access a 3.1 index).

LockTest uses an index in /tmp/index, so maybe that's where the
too-new index is being hit?

Mike McCandless

http://blog.mikemccandless.com

Mime
View raw message