lucene-pylucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andi Vajda <va...@apache.org>
Subject Re: [VOTE] Release PyLucene 2.9.4-1 and 3.0.3-1
Date Thu, 09 Dec 2010 21:55:37 GMT

On Tue, 7 Dec 2010, Andi Vajda wrote:

>
> Hi Adil,
>
>> And for both pylucene-3.0.3-1 (rc) and pylucene-3.0.2-1 when I run the make
>> tests, most of the tests run fine, but a couple of them crash Python.
>> ...
>> /opt/local/bin/python test/test_PhraseQuery.py
>> ........
>> ----------------------------------------------------------------------
>> Ran 8 tests in 0.162s
>> 
>> OK
>> /opt/local/bin/python test/test_PositionIncrement.py
>> Invalid memory access of location 0x0 eip=0x240ba3b
>> make: *** [test] Error 1
>> 
>> I have tested this on three of our 10.5 systems, and it is reproduceable on
>> all. (The unit tests complete okay on 10.6). I have tried switching to Java
>> 6 and/or Python 2.7, and I still get the same behaviour.  This crash is not
>> a show-stopper for us. Pylucene is working fine for what we need.
>
> Hmm, let me try this on my 10.5 system and report back.
> If someone else can try this before I get to it, please us know what you see.

There was indeed a bug with using Java 1.5 where the JNI version was still 
1.4. This caused some cached methods to be NULL instead of correct pointers.

I fixed this on JCC's trunk (also used by the release candidates) and I 
should be preparing new release artifacts shortly.

Andi..

Mime
View raw message