lucene-pylucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Janssen <jans...@parc.com>
Subject Re: [VOTE] Release PyLucene 2.9.4-1 and 3.0.3-1
Date Tue, 07 Dec 2010 18:24:56 GMT
>>>>> "Adil" == Adil Lotia <adil.lotia@gmail.com> writes:

    Adil> Hi Andi I downloaded the release candidate from your staging
    Adil> area, and will be running pylucene on OS X.  I am not sure if
    Adil> this is intentional, but was there a reason for this specific
    Adil> change?

    Adil> adil:681 lucene $ diff pylucene-3.0.2-1/jcc/setup.py
    Adil> pylucene-3.0.3-1/jcc/setup.py ...  47c47 < 'darwin':
    Adil> '/System/Library/Frameworks/JavaVM.framework/Versions/Current',
    Adil> ---
    >> 'darwin':
    Adil> '/Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/JavaVM.framework/Versions/Current',
    Adil> ...

    Adil> I have the standard JDK installation, which is in /System.

As I understand it, Apple is preparing to move to something like the JRE
under /System, and the JDK under /Developer/...  (which sort of makes
sense).  So development tools like "jar" and "javac" will move to the
/Developer tree.

    Adil> Also, this is my system config: adil:689 lucene $
    Adil> /usr/bin/sw_vers ProductName: Mac OS X ProductVersion: 10.5.8
    Adil> BuildVersion: 9L31a

    Adil> adil:690 lucene $ python -V Python 2.6.6

    Adil> adil:691 lucene $ java -version java version "1.5.0_26"
    Adil> Java(TM) 2 Runtime Environment, Standard Edition (build
    Adil> 1.5.0_26-b03-376-9M3263) Java HotSpot(TM) Client VM (build
    Adil> 1.5.0_26-156, mixed mode, sharing) adil:692 lucene

This is a pretty non-standard Mac.  OS X 10.5.8 uses Python 2.5.1, not
2.6.6.  And the "standard" Java is 1.6.0_22, though I also usually
compile with 1.5.

Bill

Mime
View raw message