lucene-pylucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Janssen <jans...@parc.com>
Subject Re: building PyLucene 3.0.2 on Win7/MinGW with Python 2.7
Date Wed, 01 Dec 2010 13:18:32 GMT
Andi Vajda <vajda@apache.org> wrote:

> I believe MSVC 2008 == 9.0 but I could be wrong. I also seem to recall
> that Python 2.7 requires that version. So you should also try Python
> 2.6 on Win 7.

I asked about this on the mingw list, with the following result:

Charles Wilson <cwilso11@users.sourceforge.net> wrote:

> The official python.org win32 python26 distribution
> uses the msvcr90.dll libc; anything compiled with mingw uses the
> msvcrt.dll, and THAT may be the problem.
> 
> See here:
> http://jove.prohosting.com/iwave/ipython/issues.html
> ...
> There is a way to hack your mingw
> installation to use the msvcr90.dll runtime, but I've never tried it
> myself. See this wiki page:
> http://www.mingw.org/wiki/HOWTO_Use_the_GCC_specs_file

I'll try that -- getting mingw to use the same C library that Python
uses.  Looks like you can do an in-place update -- the pyMinGW toolkit
provides a tool which does that.

Bill

Mime
View raw message