lucene-pylucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andi Vajda <va...@apache.org>
Subject Re: [VOTE] Release PyLucene 2.9.4-1 and 3.0.3-1 (take 2)
Date Fri, 10 Dec 2010 20:11:56 GMT

On Dec 10, 2010, at 10:24, Bill Janssen <janssen@parc.com> wrote:

> Andi Vajda <vajda@apache.org> wrote:
>
>> A bug was reported against the previous release artifacts that  
>> blocked the
>> release. The bug got fixed and new artifacts were uploaded, please
>> vote again.
>
> This new candidate breaks immediately on OS X 10.5.8 (standard system
> Python, standard system Java):
>
>  /tmp 18 % cd pylucene-3.0.3-1/jcc
>  /tmp/pylucene-3.0.3-1/jcc 19 % python setup.py build
>  Traceback (most recent call last):
>    File "setup.py", line 75, in <module>
>      ''' %(JDK[platform]))
>  RuntimeError:
>
>  Java JDK directory '/Developer/SDKs/MacOSX10.6.sdk/System/Library/ 
> Frameworks/JavaVM.framework/Versions/Current' does not exist.
>
>  Please set the environment variable JCC_JDK to the correct location  
> before
>  running setup.py.
>  %
>
> Andi, if you're going to just hardcode a JDK path in for OS X,  
> please at
> least hardcode the path advised by the Apple Java engineers (see
> previous mail), instead of one that's guaranteed to break on 10.5
> machines.  I say "guaranteed", because the Xcode for 10.5 doesn't
> include a 10.6 SDK, and if it did it wouldn't fit the installed Java.

So, it's "broken on 10.6 out of the box" vs "broken on 10.5 out of the  
box" or am I missing something else here ?

Andi..

>
> Bill

Mime
View raw message