lucene-pylucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Heimes <li...@cheimes.de>
Subject Re: Problems passing PyLucene objects to jcc-wrapped bobo-browse api
Date Tue, 18 May 2010 20:06:10 GMT
> The Makefile has about a dozen sets of defaults for a variety of platforms.
> Pick the one closest to your setup, uncomment it (and change it if needed).
> Then you don't have to enter these on the command line.

My point is that you may want to remove most examples and replace them 
with sensible defaults that work for all Un*x platforms and Python 2.5+.

> This is how I solved this on Windows. I'll try to see if the same trick
> works on Linux. If it does, then the export=True parameter would become
> unnecessary. Still, unless the dynamic loader can find _lucene.so on its own
> (and it should be via some -rpath tricks), loading the --import'ed module
> first might still be a good idea.

I tried to implement the very same feature. You beat me to it. :) It's 
working very well on Linux. How did you trick the linker to include 
_lucene.so as a dependency? The -l option obviously doesn't work since 
the shared library has no "lib" prefix.

> I'd very much like to try to reproduce your problems with your software.
> Is there any way I can get your stuff and build it here ?
> It would be much easier to debug this if we worked with the same stuff.

I'll send you a new Makefile and some example code tomorrow. In the mean 
time I'm happy to write that your changes have fixed the issue with 
class_ and the missing OrderHitsDesc enum.

>>> bobobrowse.FacetSpec.FacetSortSpec.OrderHitsDesc
<FacetSpec$FacetSortSpec: OrderHitsDesc>

>> - I've run into a rather strange bug with our custom builds of Python 2.6. It
>> differs from the stock build of Ubuntu in two ways. The python2.6 binary is
>> linked against libpython2.6.so (Ubuntu's python2.6 binary has libpython2.6.a
>> statically linked in) and I've set the environment variable LD_RUN_PATH which
>> causes the linker to add a "library rpath" to all ELF binaries. I wasn't able
>> to find the reason for the issue so far. Any hints are appreciated.
>
> You didn't describe the "rather strange bug" or am I missing something ?

Uups, I hit the send button too early. Sorry

The rather strange bug is that the bobobrowse package doesn't contain 
any of the bobobrowse classes when I compile JCC, PyLucene and 
Bobo-Browse inside our environment. Let's see how it's behaving with 
your latest changes.

Christian

Mime
View raw message