lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Baris Kazar <baris.ka...@oracle.com>
Subject Re: "java.lang.IllegalArgumentException: Could not load codec 'Lucene60'. Did you forget to add lucene-backward-codecs.jar?" Error
Date Sat, 28 Jul 2018 19:40:18 GMT
well, fixing path did not fix this problem
Caused By: java.lang.IllegalArgumentException: An SPI class of type org.apache.lucene.codecs.Codec
with name 'Lucene60' does not exist.  You need to add the corresponding JAR file supporting
this SPI to your classpath.  The current classpath supports the following names: [Lucene62]

Best regards

----- Original Message -----
From: baris.kazar@oracle.com
To: java-user@lucene.apache.org
Sent: Saturday, July 28, 2018 2:59:00 PM GMT -05:00 US/Canada Eastern
Subject: Re: "java.lang.IllegalArgumentException: Could not load codec 'Lucene60'. Did you
forget to add lucene-backward-codecs.jar?" Error

Ok, resolved. i thought i included 6.6.0 in the path but 6.1.0 was still there.
Thanks

----- Original Message -----
From: baris.kazar@oracle.com
To: java-user@lucene.apache.org
Sent: Saturday, July 28, 2018 2:45:08 PM GMT -05:00 US/Canada Eastern
Subject: Re: "java.lang.IllegalArgumentException: Could not load codec 'Lucene60'. Did you
forget to add lucene-backward-codecs.jar?" Error

Caused By: java.lang.IllegalArgumentException: An SPI class of type org.apache.lucene.codecs.Codec
with name 'Lucene60' does not exist.  You need to add the corresponding JAR file supporting
this SPI to your classpath.  The current classpath supports the following names: [Lucene62]

Any suggestions?
Best regards

----- Original Message -----
From: baris.kazar@oracle.com
To: java-user@lucene.apache.org
Sent: Saturday, July 28, 2018 2:42:12 PM GMT -05:00 US/Canada Eastern
Subject: "java.lang.IllegalArgumentException: Could not load codec 'Lucene60'. Did you forget
to add lucene-backward-codecs.jar?" Error

 Lucene 6.1.0 is ok but Lucene 6.6.0 issues an error related to codecs.
i dont want to modify META-INF.
 https://urldefense.proofpoint.com/v2/url?u=https-3A__bugzilla.redhat.com_show-5Fbug.cgi-3Fid-3D1352985&d=DwIFaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=nlG5z5NcNdIbQAiX-BKNeyLlULCbaezrgocEvPhQkl4&m=-mACHGGlnAFryI16jt6WZVRqkSzlFDSCzJKWZxSNyoM&s=ZZpA8PGSLfdfLA7IbJZBCk6J5KdR8dYZZfqJ3tKOsuI&e=
Any suggestions please?
Best regards

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message