lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felton Fei <felton.s...@gmail.com>
Subject Re: DocValue not replicated
Date Wed, 06 May 2015 19:53:02 GMT
Thanks Erick, 
The strange thing we found is only after 2 poll. The doc value is updated.
The first poll seems not replicate the doc value.
Our interval setting is 1m, after 2-3 mins, everything is normal. Could it
caused by the delay loading of doc values?
Thanks!

On 2015-05-03, 12:27 PM, "Erick Erickson" <erickerickson@gmail.com> wrote:

>In the master/slave setup (not SolrCloud), there's _always_ a delay by
>definition until after the polling interval expires.
>
>No other changes you make to your index will be visible until the next
>index update on the slave, triggered by the poll, docValues should be
>no different.
>
>Best,
>Erick
>
>On Thu, Apr 30, 2015 at 6:20 PM, Felton Fei <felton.solr@gmail.com> wrote:
>> Hi,
>> I have SOLR 4.9 with master/slave architecture. And I use DocValue for
>> custom ranking. After I update doc on master, it looks like the
>>DocValue not
>> get replicated to slave. After I wait for next poll from slave, it¹s
>>OK. Is
>> there a delay of replicate or loading of DocValues?
>> Thanks a lot!
>>
>>
>>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
>For additional commands, e-mail: java-user-help@lucene.apache.org
>



---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message