lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shai Erera <ser...@gmail.com>
Subject Re: A SPI class of type org.apache.lucene.codecs.Codec with name 'Lucene42' does not exist
Date Sat, 13 Jul 2013 18:54:57 GMT
Semantics :).

I was just curious cause I thought that got resolved after we removed the
RMI dependency in Searchable.

Shai


On Sat, Jul 13, 2013 at 9:39 PM, Robert Muir <rcmuir@gmail.com> wrote:

> No, it means Android cannot run Lucene 4. We are just following the java
> api specs. Android doesn't implement java, its not java.
>
> On Sat, Jul 13, 2013 at 2:23 PM, Shai Erera <serera@gmail.com> wrote:
>
> > Hmm, does that mean that Lucene 4.0+ cannot run on Android?
> >
> > Shai
> >
> >
> > On Sat, Jul 13, 2013 at 6:51 PM, VIGNESH S <vigneshklncit@gmail.com>
> > wrote:
> >
> > > Hi Robert,
> > >
> > > Thanks for your reply.
> > >
> > > If possible,can you please explain why this new class loading mechanism
> > was
> > > introduced in Lucene 4
> > >
> > > Thanks and Regards
> > > Vignesh
> > >
> > >
> > > On Sat, Jul 13, 2013 at 6:56 PM, Robert Muir <rcmuir@gmail.com> wrote:
> > >
> > > > Open a bug with android team... the problem is android isn't java
> (and
> > > > doesnt implement/follow the spec)
> > > >
> > > > On Sat, Jul 13, 2013 at 4:31 AM, VIGNESH S <vigneshklncit@gmail.com>
> > > > wrote:
> > > >
> > > > > Hi,
> > > > >
> > > > > I did not striped META-INF/services and it contains the files.
> > > > >
> > > > > Even when i combined with other jars,i manually appended those
> > entries
> > > in
> > > > > Meta-inf/services..
> > > > >
> > > > > The problem has some thing to do with the way android loads
> classes.
> > > > >
> > > > > any comments welcome.
> > > > >
> > > > >
> > > > > Thanks adnd Regards
> > > > > Vignesh
> > > > >
> > > > >
> > > > > On Sat, Jul 13, 2013 at 1:57 PM, Thomas Matthijs <lists@selckin.be
> >
> > > > wrote:
> > > > >
> > > > > > On Sat, Jul 13, 2013 at 10:25 AM, VIGNESH S <
> > vigneshklncit@gmail.com
> > > >
> > > > > > wrote:
> > > > > >
> > > > > > > Hi,
> > > > > > >
> > > > > > > I tried indexing in Desktop..It works fine.
> > > > > > > The above error loading error comes only in android..
> > > > > > > Any comments..
> > > > > >
> > > > > >
> > > > > > Don't strip META-INF/services files out of the jars
> > > > > >
> > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Thanks and Regards
> > > > > Vignesh Srinivasan
> > > > > 9739135640
> > > > >
> > > >
> > >
> > >
> > >
> > > --
> > > Thanks and Regards
> > > Vignesh Srinivasan
> > > 9739135640
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message