lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael McCandless <luc...@mikemccandless.com>
Subject Re: MultiFields.getReader() returns null
Date Tue, 16 Jul 2013 11:36:46 GMT
MultiFields.getFields returns null if the reader has no postings.  Are
you sure you actually indexed any content?

Mike McCandless

http://blog.mikemccandless.com


On Tue, Jul 16, 2013 at 3:06 AM, VIGNESH S <vigneshklncit@gmail.com> wrote:
> Hi,
>
> I am creating index like this in\\using Lucene 4.3.1
>
> I am using 3 fields like
>
> FieldType offsetsType = new FieldType(TextField.TYPE_STORED);
> offsetsType.setIndexed(true);
> offsetsType.setStored(true);
> offsetsType.setStoreTermVectors(true);
> offsetsType.setTokenized(true);
> offsetsType.setStoreTermVectorOffsets(true);
> offsetsType.setIndexOptions(IndexOptions.DOCS_AND_FREQS_AND_POSITIONS_AND_OFFSETS);
> Document doc = new Document();
>  Field body = new Field(ContentIndex.KEY_TEXTCONTENT, "", offsetsType);
>  body.setStringValue(content);
>
>
> In Search, I am using code like this
>
> Fields fields = MultiFields.getFields(mReader);
>
> It returns null in Fields..What can be the problem
>
>
>
>
>
> --
> Thanks and Regards
> Vignesh Srinivasan
> 9739135640

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message