lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler" <...@thetaphi.de>
Subject RE: Migrate/Upgrade frommLucene 2.3
Date Mon, 11 Mar 2013 07:41:41 GMT
If you use StandardAnalyzer, you are in trouble unless you use StandardAnalyzer with Version.LUCENE_23
and you are using non-western language. If you change your code to use Version.LUCENE_41,
you have to reindex.

-----
Uwe Schindler
H.-H.-Meier-Allee 63, D-28213 Bremen
http://www.thetaphi.de
eMail: uwe@thetaphi.de


> -----Original Message-----
> From: Ramprakash Ramamoorthy [mailto:youngestachiever@gmail.com]
> Sent: Monday, March 11, 2013 8:38 AM
> To: java-user@lucene.apache.org
> Subject: Migrate/Upgrade frommLucene 2.3
> 
> Dear all,
> 
>         We are moving our codebase from Lucene 2.3 to 4.1. Also, we are
> migrating the older indices from 2.3 to 3.6 and then to 4.1. Would be glad if
> you can share some do's and dont's during migrating the indices, which you
> have experienced before.
> 
>         Also, the 2.3 indices were written using a standard analyzer then and the
> current indices will use standard analyzer, version_41. Hope there shouldn't
> be a problem reading the migrated indices because of the analyzer version
> change? Thanks in advance. Glad if you can help.
> 
> --
> With Thanks and Regards,
> Ramprakash Ramamoorthy,
> India.
> +91 9626975420


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message