lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Rowe <sar...@gmail.com>
Subject Re: Migrating SnowballAnalyzer to 4.1
Date Thu, 28 Feb 2013 18:46:48 GMT
Hi Peng,

Take a look at the release docs: <http://lucene.apache.org/core/4_1_0/index.html>

In particular, in the API Javadocs section, the analyzers-common documentation has a large
list of per-language analyzers.  EnglishAnalyzer is under the org.apache.lucene.analysis.en
package: <http://lucene.apache.org/core/4_1_0/analyzers-common/org/apache/lucene/analysis/en/package-summary.html>

Steve

On Feb 28, 2013, at 1:28 PM, Peng Gao <pgao@esri.com> wrote:

> Hi,
> 
> I have a Lucene 2.9.x app that uses org.apache.lucene.analysis.snowball.SnowballAnalyzer
for
> index generation,
> 
>  analyzer = new SnowballAnalyzer("English", StopAnalyzer.ENGLISH_STOP_WORDS);
> 
> and I want to upgrade it to 4.1.
> 
> SnowballAnalyzer is deprecated in 4.1. The doc simply states
> 
> "Deprecated. (3.1) Use the language-specific analyzer in modules/analysis instead. This
analyzer will be 
> removed in Lucene 5.0."
> 
> I can't figure out how to rewrite it using 4.1 API. Could you help?
> 
> Thanks,
> Peng
> 
> Т���������������������������������������������������������������������ХF�V�7V'67&�&R�R���â�f�W6W"�V�7V'67&�&T�V6V�R�6�R��&pФf�"FF�F����6����G2�R���â�f�W6W"ֆV��V6V�R�6�R��&pР�


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message