lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Rowe <sar...@gmail.com>
Subject Re: Upgrade Lucene to latest version (4.0) from 2.4.0
Date Wed, 09 Jan 2013 21:33:43 GMT
I don't think there is a migration guide from 2.X to 3.X, other than the specific information
in the release notes.

If you start reading CHANGES.txt at version 3.0.0, and then each later release's notes after
that, especially the sections "Changes in backwards compatibility policy", e.g. for 3.0.0:
<http://lucene.apache.org/core/4_0_0/changes/Changes.html#3.0.0.changes_in_backwards_compatibility_policy>,
and "API Changes", you'll get a good picture of the changes you need to make to your code.

On Jan 9, 2013, at 4:08 PM, saisantoshi <saisantoshi76@gmail.com> wrote:

> Is there any migration guide from 2.x to 3.x? ( as per the suggestion, i
> would like to upgrade first from 2.4.0 to 2.9.0 and from 2.9.0 to 3.6) and
> later we decide if we want to upgrade from 3.6 to 4.x version?
> 
> 
> 
> --
> View this message in context: http://lucene.472066.n3.nabble.com/Upgrade-Lucene-to-latest-version-4-0-from-2-4-0-tp4031956p4032029.html
> Sent from the Lucene - Java Users mailing list archive at Nabble.com.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-user-help@lucene.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message