lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Igal @ getRailo.org" <i...@getrailo.org>
Subject Re: Upgrade Lucene to latest version (4.0) from 2.4.0
Date Wed, 09 Jan 2013 19:08:50 GMT
the API has changed much over time so I suspect that it will take more 
than replacing the jars.


On 1/9/2013 11:04 AM, saisantoshi wrote:
> We have an existing application which uses Lucene 2.4.0 version. We are
> thinking of upgrading it to alatest version (4.0). I am not sure the process
> involved in upgrading to latest version. Is it just copying of the jars? If
> yes, what are all the jars that we need to copy over. Will it be backward
> compatible? Any additional measures we need to take care of?
>
> With version 2.4.0, we have the following jars:
> lucene-core-2.4.0.jar
> lucene-analyzers-2.4.0.jar
>
> With 4.0:
> lucene-analyzers-common-4.0.0.jar
> lucene-analyzers-icu-4.0.0.jar
> lucene-core-4.0.0.jar
>
> Any advise on this is much appreciated?
>
> Thanks,
> Sai.
>
>
>
>
> --
> View this message in context: http://lucene.472066.n3.nabble.com/Upgrade-Lucene-to-latest-version-4-0-from-2-4-0-tp4031956.html
> Sent from the Lucene - Java Users mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-user-help@lucene.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message