lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "dizh@neusoft.com" <d...@neusoft.com>
Subject GroupingSearch return 0 when setAllGroups(true)
Date Wed, 28 Nov 2012 12:53:42 GMT
Is this a bugļ¼Ÿ

when using group function, I set "groupingSearch.setAllGroups(true);", but it return groupCount
= 0

I saw the source , I found that : 			

if (allGroupHeads) {
				collectors.add(allGroupsCollector);
}
if (allGroupHeads) {
				collectors.add(allGroupHeadsCollector);
}

It seemed that it should use allGroup flag, not allGroupHeads.

I am a newbie to Lucene, so I want to ask whether it is right?
---------------------------------------------------------------------------------------------------
Confidentiality Notice: The information contained in this e-mail and any accompanying attachment(s)

is intended only for the use of the intended recipient and may be confidential and/or privileged
of 
Neusoft Corporation, its subsidiaries and/or its affiliates. If any reader of this communication
is 
not the intended recipient, unauthorized use, forwarding, printing,  storing, disclosure or
copying 
is strictly prohibited, and may be unlawful.If you have received this communication in error,please

immediately notify the sender by return e-mail, and delete the original message and all copies
from 
your system. Thank you. 
---------------------------------------------------------------------------------------------------
Mime
View raw message