lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhang, Lisheng" <Lisheng.Zh...@BroadVision.com>
Subject RE: lucene Indexer failed to close, but later indexing still OK?
Date Tue, 07 Aug 2012 00:34:34 GMT
Hi,

Since last time I reported the issue below, I had a few similar issue, like at one
time when I ran CheckIndex, I got error like some delete file not found, but after
a few seconds CheckIndex is 100% OK.

Is this a problem only happening in 2.3.2 but fixed in later release (sometimes data
is corrupted but later healed itself)?

Thanks very much for helps, Lisheng



-----Original Message-----
From: Zhang, Lisheng [mailto:Lisheng.Zhang@broadvision.com]
Sent: Thursday, August 02, 2012 10:56 AM
To: java-user@lucene.apache.org
Subject: lucene Indexer failed to close, but later indexing still OK?


Hi,
 
We are using lucene 2.3.2 on linux/ubuntu (we will upgrade lucene soon), recently we got exception:
 
read past EOF #012java.io.IOException: read past EOF
at org.apache.lucene.store.BufferedIndexInput.readBytes(BufferedIndexInput.java:130)
at org.apache.lucene.index.CompoundFileReader$CSIndexInput.readInternal(CompoundFileReader.java:240)
at org.apache.lucene.store.BufferedIndexInput.refill(BufferedIndexInput.java:152)
at org.apache.lucene.store.BufferedIndexInput.readByte(BufferedIndexInput.java:38)
at org.apache.lucene.store.IndexInput.readVInt(IndexInput.java:76)
at org.apache.lucene.index.TermBuffer.read(TermBuffer.java: 63)
at org.apache.lucene.index.SegmentTermEnum.next(SegmentTermEnum.java:123)
at org.apache.lucene.index.SegmentTermEnum.scanTo(SegmentTermEnum.java:154)
at org.apache.lucene.index.TermInfosReader.scanEnum(TermInfosReader.java:223)
at org.apache.lucene.index.TermInfosReader.get(TermInfosReader.java:217)
at org.apache.lucene.index.SegmentTermDocs.seek(SegmentTermDocs.java:54)
at org.apache.lucene.index.IndexReader.termDocs(IndexReader.java:668)
at org.apache.lucene.index.IndexReader.deleteDocuments(IndexReader.java:756)
at org.apache.lucene.index.IndexWriter.applyDeletes(IndexWriter.java:3512)
...
 
This happened when we tried to commit the change. But later we ran the CheckIndex, there is
no error
at all and we can still index without problem. 
 
Is this a know issue (I searched Google, it is said if applying 4.0 to old index data we may
encounter this
error, but we all use lucene 2.3.2)?
 
Thanks very much for helps!
 
Lisheng


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org

Mime
View raw message