lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Bowyer <gbow...@fastmail.co.uk>
Subject Re: PyLucene Error Message
Date Thu, 29 Mar 2012 16:29:41 GMT
Wow a VM / hotspot crash, are you using threads ?

If you are make sure you have correctly attached the vm env to each new 
thread *after* you have initialised it on the main thread

This is done with the following
lucene.getVMEnv().attachCurrentThread()

On 29/03/2012 09:10, David Mosca wrote:
> I have re-attached the log.
>
> Thanks,
>
> David
>
>
> -----Original Message-----
> From: Greg Bowyer [mailto:gbowyer@fastmail.co.uk]
> Sent: 29 March 2012 16:55
> To: java-user@lucene.apache.org
> Subject: Re: PyLucene Error Message
>
> I dont see any attached log, can you attach the log please.
>
> -- Greg
> On 29/03/2012 07:35, David Mosca wrote:
>> Hello,
>>
>> I am using Lucene version 3.4 through the Python extension (pylucene)
>> in a multi-threaded script. When I launch the script I sometimes get a
>> fatal error message (log attached) and sometimes not (I always launch
>> the same script, exactly in the same way). When I get the error
>> message I keep launching the script again until the script stops
>> crashing (it sometimes takes up to 5 or 6 times).
>>
>> Could you please have a look into this?
>>
>> Thank you.
>>
>> *David*
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
>> For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message