lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dhruv <dhru...@gmail.com>
Subject Applying LUCENE-3653 patch to Lucene 3.0.3
Date Tue, 07 Feb 2012 21:45:28 GMT
Hi,

My company is using an older version of Lucene (3.0.3). In my profiling
results with 3.0.3, I have found that my app's threads were blocked due to
the issue mentioned at LUCENE-3653. Although I was able to use the 3.6 line
which fixes this problem, we are still in the process of conducting
performance regression testing with Lucene 3.5.3. I would like to apply the
LUCENE-3653 patch to the 3.0.3 line and compare the results. However, I
can't apply the patch because of a missing
"lucene/src/java/org/apache/lucene/index/SegmentCoreReaders.java" file in
the 3.0.3 line.

Can someone please point out a rough draft of what is involved in modifying
3.0.3 to just accomodate LUCENE-3653? Can I just strip out the changes
affecting SegmentCoreReader.java?

Thanks,
-Dhruv

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message