lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From SBS <jturn...@uow.edu.au>
Subject Re: PorterStemFilter causes wildcard searches to not work
Date Tue, 29 Nov 2011 07:25:05 GMT
I am applying the PorterStemFilter at both indexing and search time.

As for schema, I have 3 fields: title, subtitle and notes.  When the user
enters a query string of */a*itis/*, my software turns this into an actual
Lucene query of */title: a*itis OR subtitle: a*itis OR notes: a*itis/* and I
get the results I described.  However, if I run an actual query of just
*/a*itis/* I then get the results I am looking for.  I guess in this case
it's using the default field that I specify in creating the QueryParser
which is "notes" but if I change the actual query to */notes: a*itis/* I
still get the undesirable results.

Any idea why I am seeing this behaviour?  Again, if I remove the
PorterStemFilter from my custom analyzer (which I use at both indexing and
search time) then I get the results I want (albeit I lose the other
functionality which I also need).

--
View this message in context: http://lucene.472066.n3.nabble.com/PorterStemFilter-causes-wildcard-searches-to-not-work-tp3525790p3544411.html
Sent from the Lucene - Java Users mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message