lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Muir <rcm...@gmail.com>
Subject Re: Lucene killing JVM
Date Fri, 09 Sep 2011 14:02:05 GMT
Why not? its not our bug, its Oracle's bug.

Personally I would us a more stable JRE version rather than one so
new, like 1.6.0_18 or 1.6.0_19

On Fri, Sep 9, 2011 at 6:05 AM, Dragan Jotanovic
<dragan.jotanovic@diosphere.com> wrote:
> Looks like the problem is somewhere in MMapFSDirectory. As soon as I
> switched to NIOFSDirectory, JVM stopped crashing. Maybe MMapFSDirectory
> shouldn't be default FSDirectory on 64bit Linux ater all?
>
> Dragan
>
>
> On 9/1/2011 11:51 AM, Uwe Schindler wrote:
>>
>> Hi,
>>
>> If the other suggestions for checking RAM don't help, please remove all
>> JVM
>> parameters from command line like the special GC configuration:
>>
>> jvm_args:
>> -Djava.util.logging.config.file=/var/lib/tomcat6/conf/logging.properties
>> -Djava.awt.headless=true -Xms4000M -Xmx4000M -XX:PermSize=400m
>> -XX:MaxPermSize=400m -XX:+UseConcMarkSweepGC -XX:+UseParNewGC
>> -XX:+UseConcMarkSweepGC
>> -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
>> -Djava.endorsed.dirs=/usr/share/tomcat6/endorsed
>> -Dcatalina.base=/var/lib/tomcat6 -Dcatalina.home=/usr/share/tomcat6
>> -Djava.io.tmpdir=/tmp/tomcat6-tmp
>>
>> The first thing I looked at was if you have aggressive optimizations
>> enabled, but that's not the case, so you are fine :-)
>>
>> Uwe
>>
>> -----
>> Uwe Schindler
>> H.-H.-Meier-Allee 63, D-28213 Bremen
>> http://www.thetaphi.de
>> eMail: uwe@thetaphi.de
>>
>>
>>> -----Original Message-----
>>> From: Dragan Jotanovic [mailto:dragan.jotanovic@diosphere.com]
>>> Sent: Thursday, September 01, 2011 11:13 AM
>>> To: java-user@lucene.apache.org
>>> Subject: Lucene killing JVM
>>>
>>> Hi,
>>> I recently upgraded to lucene 3.3 (from 3.0.3) and now my JVM keeps
>>
>> crashing.
>>>
>>> I noticed that it happens when I'm closing and reopening my index. It
>>
>> doesn't
>>>
>>> happen every time. Sometimes it works for days and sometimes it crashes
>>> several times a day. Usually there is no exception in log files, only
>>> that
>>
>> JVM dies
>>>
>>> and error report file is created.
>>> Index server is running on Tomcat 6, Ubuntu server 10.04, Sun JVM
>>> 1.6.0_26
>>> Here's two examples of error report files:
>>> http://pastebin.com/wmQy0rw8
>>> http://pastebin.com/TYQmyHAP
>>>
>>> Did anyone else experience something similar? Is this a known bug in
>>
>> Lucene or
>>>
>>> a JVM bug?
>>>
>>> Dragan
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
>>> For additional commands, e-mail: java-user-help@lucene.apache.org
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
>> For additional commands, e-mail: java-user-help@lucene.apache.org
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-user-help@lucene.apache.org
>
>



-- 
lucidimagination.com

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message