lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "cheng" <zhoucheng2...@gmail.com>
Subject RE: Lucene 3.3 in Eclipse
Date Mon, 16 May 2011 08:24:27 GMT
Steve, the two links are really helpful. I still have a few questions:

1) The import statement, import org.apache.lucene.queryParser.standard.parser.StandardSyntaxParser,
doesn't work because the StandardSyntaxParser.java is not available.

Do you know where to download it?

2) The CharStream class is not available. Please see this, "public final class FastCharStream
implements CharStream"

What is it? Do you know where to download it?

3) The QueryParser class can't be resolve. Please see this, SrndQuery lq = QueryParser.parse(queryText);

Thanks,
Cheng




-----Original Message-----
From: Steven A Rowe [mailto:sarowe@syr.edu] 
Sent: Sunday, May 15, 2011 11:15 PM
To: java-user@lucene.apache.org
Subject: RE: Lucene 3.3 in Eclipse

(Resending to the list - didn't notice that my reply went to Cheng directly)

There is an Ant target "get-db-jar" that can do the downloading for you - you can see the
URL it uses here:

<http://svn.apache.org/viewvc/lucene/java/tags/lucene_3_0_3/contrib/db/bdb/build.xml?view=markup#l49>

There is another Ant target "get-je-jar" that does the same thing for the contrib/db/bdb-je/
module:

<http://svn.apache.org/viewvc/lucene/java/tags/lucene_3_0_3/contrib/db/bdb-je/build.xml?view=markup#l49>

Steve

> -----Original Message-----
> From: cheng [mailto:zhoucheng2008@gmail.com]
> Sent: Sunday, May 15, 2011 10:48 AM
> To: java-user@lucene.apache.org
> Cc: Steven A Rowe
> Subject: RE: Lucene 3.3 in Eclipse
> 
> Steve, thanks for correction. You are right. The version is 3.0.3
> released last Oct.
> 
> I did place an ant jar in Eclipse, and it does the job to remove some
> compiling errors. However, it seems that I do need some jar file to
> handle the DbHandleExtractor.java and the org.apache.lucene.store.db
> package, which are under contrib/db/bdb/src/java folder.
> 
> Do you know when I can find the proper jar file?
> 
> Cheng
> 
> -----Original Message-----
> From: Steven A Rowe [mailto:sarowe@syr.edu]
> Sent: Sunday, May 15, 2011 10:08 PM
> To: java-user@lucene.apache.org
> Subject: RE: Lucene 3.3 in Eclipse
> 
> Hi Cheng,
> 
> Lucene 3.3 does not exist - do you mean branches/branch_3x ?
> 
> FYI, as of Lucene 3.1, there is an Ant target you can use to setup an
> Eclipse project for  Lucene/Solr - run this from the top level directory
> of a full source tree (including dev-tools/ directory) checked out from
> Subversion:
> 
>    ant eclipse
> 
> More info here:
> 
> 
> <http://wiki.apache.org/solr/HowToContribute#Development_Environment_Tips
> >
> 
> Steve
> 
> > -----Original Message-----
> > From: cheng [mailto:zhoucheng2008@gmail.com]
> > Sent: Sunday, May 15, 2011 4:29 AM
> > To: java-user@lucene.apache.org
> > Subject: Lucene 3.3 in Eclipse
> >
> > Hi, I created a java project for Lucene 3.3 in Eclipse, and found that
> in
> > the DbHandleExtractor.java file, the package of
> > com.sleepycat.db.internal.Db
> > is not resolved. How can I overcome this?
> >
> >
> >
> > I have tried to download .jar for this, but don't know which and where
> to
> > download.
> >
> >
> >
> > Thanks
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message