lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pradeep Singh <pksing...@gmail.com>
Subject Re: Build environment
Date Mon, 11 Oct 2010 15:51:00 GMT
It worked with Ant 1.7.1 and maven-ant-tasks 2.0.10 and it actually built
everything - lucene, solr and analyzers (with ant generate-maven-artifacts
at the root). I had to add uniqueVersion="false" in artifact:deploy for the
macro m2-deploy in lucene/common-build.xml to stop generating new artifact
for every build and to keep a consistent name of artifact-4.0-SNAPSHOT.

Thanks

On Mon, Oct 11, 2010 at 5:44 AM, Uwe Schindler <uwe@thetaphi.de> wrote:

> Use ant 1.7.x, 1.8 is not backwards compatible and parts of Lucene  Build
> don't work (redefinition of property data types in 1.8,...). With this
> version the recent Maven-for-Ant 2.0.10 version should work.
>
> Please note that Lucene trunk does not build maven artifacts for the
> modules
> folder. Nor does it build src/bin artifacts. This is trunk and not 100%
> finished and under heavy flux.
>
> Lucene/Solr 3.x can be built as described above without probs.
>
> -----
> Uwe Schindler
> H.-H.-Meier-Allee 63, D-28213 Bremen
> http://www.thetaphi.de
> eMail: uwe@thetaphi.de
>
>
> > -----Original Message-----
> > From: Pradeep Singh [mailto:pksinghus@gmail.com]
> > Sent: Monday, October 11, 2010 5:54 AM
> > To: java-user@lucene.apache.org
> > Subject: Build environment
> >
> > Hi all,
> >
> > I am having issues building Lucene and Solr from svn checkout. I had this
> > problem earlier but I was able to figure out the combination of ant and
> maven-
> > ant-tasks that worked. Last few months I've been building with Ant
> > 1.8.1 and maven-ant-tasks 2.1.1 (I had always has ant 1.8.1 but an old
> version
> > of maven ant tasks and it would not build. I would get errors about it
> not
> finding
> > poms and those errors went away with the right version of ant tasks).
> >
> > Similar problem is occurring today (generate-maven-artifacts
> specifically)
> and I
> > suspect it has to do with this combination. I checked the hudson report
> to
> see
> > that Lucene build uses Ant 1.7.0. A short answer could possibly solve
> this
> > problem. What's the maven ant tasks version it is using?
> >
> > Could we please publish this information somewhere? Because it is clear
> that
> > "any" ant version higher than 1.6.3 is not the solution. And it sure
> needs
> a
> > specific version of maven ant tasks to work.
> >
> > Thanks,
> > Pradeep
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-user-help@lucene.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message