lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gregory Tarr" <Gregory.t...@detica.com>
Subject Unsupported operation in DocIdSetIterator using lucene 2.9
Date Wed, 12 May 2010 09:38:37 GMT
I am using lucene 2.9 and I can't understand why a succession of
un-deprecated methods calls a deprecated method in this class.
The series of calls is as follows:

Searcher.search(Query, Collector)
IndexSearcher.search(Weight, Filter, Collector)
Scorer.score(Collector)
DocIdSetIterator.nextDoc()
DocIdSetIterator.next()

The javadocs for next() say that you should call nextDoc() but yet the
nextDoc() method calls next()!

I understand it is changing in 3.0, but can this be made to work in 2.9
without editing the code?

Many thanks,

Greg Tarr


This message should be regarded as confidential. If you have received this email in error
please notify the sender and destroy it immediately.
Statements of intent shall only become binding when confirmed in hard copy by an authorised
signatory.  The contents of this email may relate to dealings with other companies within
the Detica Limited group of companies.

Detica Limited is registered in England under No: 1337451.

Registered offices: Surrey Research Park, Guildford, Surrey, GU2 7YP, England.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message