lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kannan chandrasekaran <ckanna...@yahoo.com>
Subject Is the new Lucene Query parser framework compatibility with older lucene versions ?
Date Thu, 29 Apr 2010 00:44:22 GMT
Hi All,

I have a question regarding the new Lucene query parser framework in the contribs project.
 

 My company's project is running on top of 2.4.0 release of Lucene. I am  trying to evaluate
the new query parser framework that was added to the contribs project in the Lucene 2.9.0
release and looks like it might fit our needs.  Due to some custom additions done to the core
Lucene code base,  we are currently unable to upgrade to the latest stable release.  

My questions:
1) Is it possible to use the contrib query parser framework with lucene 2.4.0 release ?  I
know the documentation hints such compatibility (http://lucene.apache.org/java/3_0_1/api/contrib-queryparser/index.html)
 but wanted to confirm the same.
2) Has anybody tried doing this before ? If yes, can you please let me know if there is anything
I should be aware of while attempting this ?
3) Since its lot more flexible than the default query parser, is there a chance it would replace
the query parser in the Lucene core ? If yes , any known timelines ? 

Kindly help me with these questions.

Thanks
Kannan



      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message