lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Miller <markrmil...@gmail.com>
Subject Re: ComplexPhraseQueryParser highlight problem
Date Mon, 02 Nov 2009 13:04:38 GMT
Yes - please share your test programs and I can investigate (ApacheCon
this week, so I'm not sure when).

And its best to keep communications on the list - that allows others
with similar issues (now or in the future) to benefit from whatever goes
on. You will also reach a wider pool of people that can possibly help or
add valuable input.


-- 
- Mark

http://www.lucidimagination.com


AHMET ARSLAN wrote:
> Hi Mark,
>
> I am using LUCENE-1486. I am having highlighting problems with it.
> With solr 1.3.0 it was working with hl.usePhraseHighlighter=true which uses SpanScorer
to highlight phrase terms only when they appear within the query phrase in the document.
>
> But when I switched to Solr 1.4 highlights disappeared. I tried to highlight using lucene
2.9.0 API, again I failed. I also tried FastVectorHighlighter but it didn't produce highlight.
I can share my test programs if you want.
>
> What could be the reason? Document are matching but highlights are missing. 
> Any pointers to enable highlighting with ComplexPhraseQuery are really appreciated. 
>
> I am writing this e-mail directly to you. If you want i can post it to lucene-java maling
list, or to LUCENE-1486. I am not sure which one is more appropriate. 
>
> Please give me some directions.
>
> Thank you for your time.
>
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around 
> http://mail.yahoo.com 
>   



---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message