lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erick Erickson" <erickerick...@gmail.com>
Subject Re: Issues with Special Characters
Date Tue, 16 Sep 2008 16:28:17 GMT
Um, ask over on the .NET user group?

Erick

On Tue, Sep 16, 2008 at 12:20 PM, miztaken <justjunktome@gmail.com> wrote:

>
> Hi,
> I tested sample application with Luke as well.
> I am using .NEt Version of Lucene (2.0.0.4) and i think i am getting error
> due to that.
>
> When i tested my queries with luke then its working fine and getting me
> output as desired but then i used lucene API available for .NET then its
> producing error.
>
> I have a field name key and i have inserted 4 documents with following
> values
> fw:
> fw: fyi.msg
> hatti ghoda
> hatti ghoda (e-mail)
>
> in luke i did following queries:
>
> Q1: key:"fw\: fyi.msg"   //with escape char  //OK
> Q2: key:"fw: fyi.msg"   //without escape char //OK
> Q3: key:fw\:              //with escape char //OK
> Q4: key:fw:            //without escape char //NOT OK
> Q5: key:"hatti ghoda (e-mail)"  //without escape char //OK
> Q6: key:"hatti ghoda \(e\-mail\)"   //with escape char //OK
>
> And with .NET API the behaviour is different.
> Q1 doesnt work
> Q2 works
> Q3 works
> Q4 throws exception
> Q5 works
> Q6 doesnt work
>
> Any suggestions?
>
>
>
> --
> View this message in context:
> http://www.nabble.com/Issues-with-Special-Characters-tp19511428p19515241.html
> Sent from the Lucene - Java Users mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-user-help@lucene.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message