lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From anandsarwade <anand.sarw...@corp.aol.com>
Subject Lucene search fails for japanese characters in URL
Date Wed, 17 Sep 2008 14:41:34 GMT

Hi ,

I am facing below problem. Please help me in this.

I have integrated CJK Analyzer for Japanese characters. I am able to save 
japanese double byte characters in mysql database in UTF-8 format without
issues. I could that data is getted indexed. Now when i search the Japanese
characters which were indexed using the URL below , returns empty results.
 
http://xml.demo.myaol.jp:8082/portal/gallery-search?first=1&max=100&cap=言語 
 
Noticed that the above url gets converted to the following URL having some
HTML encoded strings in search.
 
http://xml.demo.myaol.jp:8082/portal/gallery-search?first=1&max=100&cap=%E8%A8%80%E8%AA%9E
 
This does not match with the existing lucene indexes henceforth returns
empty results.  How do i solve this lucene search issue having japanese
words in URLs.? Is there any way to convert such characters back to Japanese
words??? 

Any help/suggestions in this regards is highly appreciated.

Thanks in Advance.

Regards,
Anand 

-- 
View this message in context: http://www.nabble.com/Lucene-search-fails-for-japanese-characters-in-URL-tp19533647p19533647.html
Sent from the Lucene - Java Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message