lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael McCandless <luc...@mikemccandless.com>
Subject Re: CorruptIndexException workaround in 2.3-SNAPSHOT? (Attn: Michael McCandless)
Date Fri, 26 Sep 2008 10:30:26 GMT

Ari Miller wrote:

> According to https://issues.apache.org/jira/browse/LUCENE-1282?focusedCommentId=12596949

> #action_12596949
> (Sun hotspot compiler bug in 1.6.0_04/05 affects Lucene), a workaround
> for the bug which causes the CorruptIndexException was put in to the
> 2.3 branch and 2.4.
> However, we are still experiencing this issue (intermittent creation
> of a corrupt index) with a 2.3-SNAPSHOT from maven.
> Was the workaround put into 2.3-SNAPSHOT?  Are there other issues
> which would cause the same error (detailed below)?
>
> We would prefer to avoid upgrading to JDK 6u10
> (http://java.sun.com/javase/downloads/ea/6u10/6u10RC.jsp) until it is
> a final release, thus the use of the 2.3-SNAPSHOT dated July 22.

Can you look in the Lucene core JAR's manifest and report back what  
version information you see?  (It should contain the timestamp that  
the JAR was built).

I committed this workaround to the 2.3 branch on May 22.

We don't currently have any automated build that pushes snapshot  
builds into maven on the 2.3 branch; my guess is that 2.3-SNAPSHOT in  
maven was from the last trunk build before 2.3 was released (which  
would not contain this fix), though I'm not sure why it has timestamp  
July 22.

Mike

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message