lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Cresswell" <stephen.cressw...@gmail.com>
Subject Fwd: Snowball not finding "purple"
Date Fri, 09 May 2008 23:26:46 GMT
For some reason it seems that either Lucene or Snowball has a problem with
the color purple. According the snowball experts the problem is with lucene.
Can anyone shed any light? Thanks,

Steve

---------- Forwarded message ----------
From: Stephen Cresswell <stephen.cresswell@gmail.com>
Date: 2008/4/22
Subject: Snowball not finding "purple"
To: snowball-discuss@lists.tartarus.org


Hi,

I'm using Compass/Lucene + snowball/English to search the following text
which appears in several documents

"The road was a ribbon of moonlight looping the purple moor,"

Searching for the word "ribbon" returns the document, but not the word
"purple"

[945354] compass.DefaultSearchableMethodFactory search defaults: {max=10,
offset=0, reload=false, escape=false}
[945397] search.DefaultSearchMethod query: [+(+(name:ribbon^8.0
firstMessageText:ribbon^0.0 text:ribbon)) +(alias:ALIASConversationALIAS)],
[4] hits, took [2] millis
[956176] compass.DefaultSearchableMethodFactory search defaults: {max=10,
offset=0, reload=false, escape=false}
[956184] search.DefaultSearchMethod query: [+(+(name:purple^8.0
firstMessageText:purple^0.0 text:purple)) +(alias:ALIASConversationALIAS)],
[0] hits, took [1] millis

If the only change I make is to switch to  Lucene's StandardAnalyzer results
for both "ribbon" and "purple" are returned

Is this a bug or is there some strange intended behavior I'm not aware of?

Thanks

Steve

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message