lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peiran Song <peir...@cs.uoregon.edu>
Subject Re: lucene 2.3.1 QueryTermExtractor error
Date Sat, 19 Apr 2008 20:11:18 GMT
That is the problem! -- an old highlight.jar
Thank you, Erick!

Erick Erickson wrote:
> Are you absolutely sure that you don't have some older jars hanging
> around in your environment? Especially when using Eclipse, the jar you
> compile with isn't necessarily the jar you run with, you have to find the
> magic runtime settings....
>
> And if you're not using eclipse, it could still be something similar...
>
> Best
> Erick
>
> On Fri, Apr 18, 2008 at 7:11 PM, Peiran Song <peirans@cs.uoregon.edu> wrote:
>
>   
>> Hi All,
>>
>> I recently upgraded Lucene to 1.9.1 and then to 2.3.1. The application
>> program compiled successfully but throws run time error:
>>
>> java.lang.NoSuchFieldError: prohibited
>>
>>  org.apache.lucene.search.highlight.QueryTermExtractor.getTermsFromBooleanQuery(QueryTermExtractor.java:91)
>>
>>  org.apache.lucene.search.highlight.QueryTermExtractor.getTerms(QueryTermExtractor.java:66)
>>
>>  org.apache.lucene.search.highlight.QueryTermExtractor.getTerms(QueryTermExtractor.java:59)
>>
>>  org.apache.lucene.search.highlight.QueryTermExtractor.getTerms(QueryTermExtractor.java:45)
>>
>>  org.apache.lucene.search.highlight.QueryScorer.<init>(QueryScorer.java:48)
>>
>> I was not able to google a solution and I hope to get some help here.
>> Thanks a lot!
>>
>> Peiran
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
>> For additional commands, e-mail: java-user-help@lucene.apache.org
>>
>>
>>     
>
>   

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message