lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erick Erickson" <erickerick...@gmail.com>
Subject Re: problem with details given by Explanation object
Date Tue, 27 Nov 2007 21:59:17 GMT
Attachments often do not come through, at least they aren't visible to
me using g-mail. So you might want to re-send them in-line.

But another thing you can do is get a copy of luke and examine
your index to see if the actual contents of doc1 and doc2 are what
you expect. You can even run queries through it (but watch to insure
that you're using the correct analyzer) and see what is returned....

Best
Erick

On Nov 27, 2007 3:54 PM, Ng Vinny <ngvinny@gmail.com> wrote:

> Hi all,
>
> I am having a problem with Lucene 2.2.0 with regard to the contents of the
> Explanation objects after a PhraseQuery search. I indexed two documents doc1
> and doc2 and then issue an OR Boolean query consisting of two PhraseQuery
> pq1 and pq2.
>
> Apparently, the details of the Explanation object for doc1 show that pq1
> has positive tf value even though it doesn't appear in doc1. The tf value is
> exactly the same as that of the tf value for pq1 in doc2 (pq1 does appear in
> doc2).
>
> The code is attached (the sample pdf files cannot be attached due to size
> restriction on the list).
>
> Please help to shed some light on this.
>
> Thank you very much
> Ng Vinny
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-user-help@lucene.apache.org
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message