lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zach Bailey <zach.bai...@hannonhill.com>
Subject Re: Lucene implmentation question
Date Wed, 19 Sep 2007 15:46:02 GMT
My next recommendation would be to manually specify the classpath by 
using the -cp or -classpath arguments, for example:

/usr/java/default/bin/java -cp /usr/java/default/lib/lucene.jar 
org.apache.lucene.demo.IndexFiles /opt/lucene/src/

By the way, you are aware that IndexFiles is not included in the 
"official" Lucene library, right? IndexFiles is a class that relies on 
Lucene, however it is distributed as a separate library as part of 
"PDFBox". Perhaps that's the problem?

-Zach

warnockm wrote:
> Thanks.  I did not realize that.  I fixed it by putting in the path, but am
> getting the same error:
> 
> [root@localhost /]# /usr/java/default/bin/java
> org.apache.lucene.demo.IndexFiles /opt/lucene/src/
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/lucene/demo/IndexFiles
> 
> 
> Zach Bailey wrote:
>> Are you aware you're using GCJ and not the Sun JVM/JDK? Your initial 
>> paragraph seems to imply you think you are using a Sun product, but your 
>> stack trace shows otherwise. Perhaps that has something to do with it - 
>> you're not actually running the "java" you think you are?
>>
>> -Zach
>>
>> warnockm wrote:
>>> This sounds like a simple problem but i cannot for the life of me figure
>>> it
>>> out.  Am running Fedora 7, JDK 1.6, and Tomcat 6.0 (although not being
>>> used
>>> for this).  I download Lucene and followed the instructions that said to
>>> place the core and demo .jar files in my classpath.  My classpath is set
>>> to
>>> java_dir/ and java_dir/lib.  I placed the .jar files in java_dir/lib. 
>>> Next,
>>> i made sure my JAVA_HOME was set.  I then tried running the example under
>>> the "Get started", which included indexing a folder from the shell.  I
>>> ran
>>> the command:
>>>
>>> java org.apache.lucene.demo.IndexFiles /opt/lucene/src/
>>>
>>> and got the following response:
>>> Exception in thread "main" java.lang.NoClassDefFoundError:
>>> org.apache.lucene.demo.IndexFiles
>>>    at gnu.java.lang.MainThread.run(libgcj.so.8rh)
>>> Caused by: java.lang.ClassNotFoundException:
>>> org.apache.lucene.demo.IndexFiles not found in
>>> gnu.gcj.runtime.SystemClassLoader{urls=[file:/usr/java/default/,file:/usr/java/default/lib/],
>>> parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
>>>    at java.net.URLClassLoader.findClass(libgcj.so.8rh)
>>>    at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.8rh)
>>>    at java.lang.ClassLoader.loadClass(libgcj.so.8rh)
>>>    at java.lang.ClassLoader.loadClass(libgcj.so.8rh)
>>>    at gnu.java.lang.MainThread.run(libgcj.so.8rh)
>>>
>>> It sounds like it can't find my Lucene class, but even when i manually
>>> point
>>> the classpath to the lib folder, i get the error.  
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
>> For additional commands, e-mail: java-user-help@lucene.apache.org
>>
>>
>>
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message