lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From warnockm <m...@warnockinc.com>
Subject Lucene implmentation question
Date Wed, 19 Sep 2007 15:17:43 GMT

This sounds like a simple problem but i cannot for the life of me figure it
out.  Am running Fedora 7, JDK 1.6, and Tomcat 6.0 (although not being used
for this).  I download Lucene and followed the instructions that said to
place the core and demo .jar files in my classpath.  My classpath is set to
java_dir/ and java_dir/lib.  I placed the .jar files in java_dir/lib.  Next,
i made sure my JAVA_HOME was set.  I then tried running the example under
the "Get started", which included indexing a folder from the shell.  I ran
the command:

java org.apache.lucene.demo.IndexFiles /opt/lucene/src/

and got the following response:
Exception in thread "main" java.lang.NoClassDefFoundError:
org.apache.lucene.demo.IndexFiles
   at gnu.java.lang.MainThread.run(libgcj.so.8rh)
Caused by: java.lang.ClassNotFoundException:
org.apache.lucene.demo.IndexFiles not found in
gnu.gcj.runtime.SystemClassLoader{urls=[file:/usr/java/default/,file:/usr/java/default/lib/],
parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
   at java.net.URLClassLoader.findClass(libgcj.so.8rh)
   at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.8rh)
   at java.lang.ClassLoader.loadClass(libgcj.so.8rh)
   at java.lang.ClassLoader.loadClass(libgcj.so.8rh)
   at gnu.java.lang.MainThread.run(libgcj.so.8rh)

It sounds like it can't find my Lucene class, but even when i manually point
the classpath to the lib folder, i get the error.  
-- 
View this message in context: http://www.nabble.com/Lucene-implmentation-question-tf4481645.html#a12779646
Sent from the Lucene - Java Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message