lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harini Raghavan" <harini.ragha...@insideview.com>
Subject Re: Lucene 2.2 + Not Merging Segments
Date Tue, 24 Jul 2007 16:46:08 GMT
I figured out the problem. The issue had nothing to do with Lucene 2.2. I
had accidentally reset the default mergeFactor to 1000. This was the reason
it was not merging the segments. With the default mergeFactor, the indexing
is working perfectly fine.

Thanks,
Harini

On 7/24/07, Michael McCandless <lucene@mikemccandless.com> wrote:
>
>
> This is spooky.  Could you provide more details about how you are using
> IndexWriter?  Are you changing "max buffered docs" from the default?
>
> Also, can you call writer.setInfoStream(System.out), capture that log, and
> post it?
>
> Mike
>
> "Harini Raghavan" <harini.raghavan@insideview.com> wrote:
> > Hi All,
> >
> > I just upgraded my application to use lucene 2.2. Prior to this, I was
> using
> > lucene 1.9.1 and the addDocument method in the IndexWriter used to keep
> > merging smaller segments while adding new documents depending on the
> > mergeFactor. I was using the default mergeFactor settings. But after the
> > upgrade, when I add documents, every time it is creating a new segment
> and
> > not merging the older ones. Within 2 hours of running, it had created
> over
> > 1000 segments. I verified the IndexWriter in the new source and it
> seemed to
> > me that there is no change to the default values.
> >
> > Has anything else changed that would affect the
> > IndexWriter.addDocumentbehaviour? Can someone shed some light on this.
> >
> > Thanks,
> > Harini
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-user-help@lucene.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message