lucene-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless" <luc...@mikemccandless.com>
Subject Re: IndexWriter Quandry
Date Wed, 04 Apr 2007 14:22:30 GMT

"Kvailis" <warthog982@yahoo.com> wrote:
> I'm pretty new to Lucene (2.0.0) and and having an issue with the
> IndexWriter: if I set the boolean argument to 'true' it goes ahead and
> writes indexes that turn out to be perfectly usable; taking the same exact
> code and swithing the boolean to 'false' immediately throws a
> FileNotFoundException for '.../segments', saying there's no such file or
> directory.  I know it's there after the first run because I can see it on
> the file system and search it.  Indexing with 'true' and then immediately
> with 'false' produces the same result, so I don't think there's any
> corruption coming from any searches.  It's not a big deal now, because the
> size of the data itself is pretty small and doesn't get updated all that
> frequently; that's going to change radically in the near future, so creating
> new indexes every time someting changes will undoubtedly be a huuge pain in
> the @$$ for the users.  Any clues will be a help and appreciated
> accordingly...

I think something sneaky must be happening here because that use case
normally works fine.  If indeed an index is present at the directory
then passing "false" will just open that existing index and add
documents to it.  Can you make the problem happen on a tiny test case?

Mike

---------------------------------------------------------------------
To unsubscribe, e-mail: java-user-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-user-help@lucene.apache.org


Mime
View raw message